Nokia 8 Bootloader

  • Hello @singhnsk, I don't seem to find an option to choose Nokia 8 from the drop down menu, doesn't it support the unofficial bootloader? alt text

  • The reason I'm choosing to try your unofficial method is that I broke my nokia 8 ta-1004 since 4 months ago, and I've tried all the methods in the internet but with no success especially using the ost tool, all I get is errors or the program freezes, now the phone is stuck on download mode permanently and all I'm able to do now is to use fastboot, that's why I started looking for alternative methods and I came up to a man in the xda forum, that suggest for me to ask you for the unofficial bootloader and try my slight chances of recovering the phone back, so far my bootloader is not unlocked:

    fastboot getvar all


    (bootloader) unlocked:no
    (bootloader) off-mode-charge:1
    (bootloader) charger-screen-enabled:1
    (bootloader) battery-soc-ok:yes
    (bootloader) battery-voltage:3844
    (bootloader) version-baseband:
    (bootloader) version-bootloader:
    (bootloader) variant:MSM UFS
    (bootloader) partition-type:userdata:ext4
    (bootloader) partition-size:userdata: 0xCEC456000
    (bootloader) partition-type:system_a:ext4
    (bootloader) partition-size:system_a: 0xE0000000
    (bootloader) has-slot:modem:yes
    (bootloader) has-slot:system:yes
    (bootloader) current-slot:a
    (bootloader) has-slot:boot:yes
    (bootloader) slot-retry-count:b:0
    (bootloader) slot-unbootable:b:no
    (bootloader) slot-successful:b:no
    (bootloader) slot-retry-count:a:0
    (bootloader) slot-unbootable:a:yes
    (bootloader) slot-successful:a:no
    (bootloader) slot-count:2
    (bootloader) slot-suffixes:_a,_b,
    (bootloader) secure:yes
    (bootloader) serialno:NB1GAD178080xxxx
    (bootloader) product:QC_Reference_Phone
    (bootloader) max-download-size:0x20000000
    (bootloader) kernel:uefi
    (bootloader) version:0.0
    finished. total time: 0.032s

    and I cannot change slots:

    fastboot --set-active=b


    Setting current slot to 'b'...
    FAILED (remote: Slot Change is not allowed in Lock State
    finished. total time: 0.003s

  • Admin

    Hi @SalahGFX

    I am sorry to hear the problems faced by you with your Nokia 8. The 8 was/is definitely supported, but I stopped offering it since we do have an official unlock and there's no point for anybody to be paying for something which freely exists. That said, I definitely can generate a key for your Nokia 8. I'd however need to know more about your phone. Most importantly, the software release that it is running right now. If you have any idea of the security patch installed, please do let me know.

    If not, please let me know the output of this command: fastboot oem getversions. This won't tell us the security patch, but we can make a fair guess from the build number installed on the phone.

    The reason I need this is because the unofficial will only work on a pre-August software release.

    Also, can you tell more about what exactly happened to the phone. I mean.. how did it die? That can give some idea relating to if it is some hardware gone wrong or entirely software.

  • Hi @singhnsk , well basically after 1 month from when I bought the phone and exactly when I upgrade the Android to Oreo 8.0, I noticed that the wifi switcher stopped responding, so I was like should I downgrade or something? and I wasn't aware of the fact that it was just an upgrade issue, since it didn't come right away, so I started diving into the Nokia 8 flashing forum and read about the tools provided at that moment and I happened to use the OST tool, at first I've downgrade to 7.0 then try to upgrade to 8.0 but with no success, the same issue still causing errors, and that alone starts to frustrating me since being able to connect to the internet is something I cannot just close my eye on, so I happened to find a thread about a new OTA zip, I'm not sure if it was the June patch or the August one, all I remember is that once I tried to flash it using the traditional recovery mode it stops working, and then after awhile of butchering the phone and trying different versions of nb0 using OST tool v6.0.4 and v6.1.2, I have officially brook my phone and right the only thing I see over and over is the download mode screen with the "POWERED BY android" in the center, right know it will hit approximately 4 months, so I started loosing interest in fixing until I got the fastboot working again by accident, and I'm hopping I can fix my phone by your help!

    fastboot oem getversions


    (bootloader) model=NB1
    (bootloader) sub_model=none
    (bootloader) software version=NB1-484F-0-00WW-B01
    (bootloader) SW model=00WW
    (bootloader) build number=B01
    (bootloader) hardware version=3.1
    (bootloader) RF band id=G_850_900_1800_1900^W_1_2_4_5_8^L_1_2_3_4_5_7_8_
    OKAY [  0.001s]
    finished. total time: 0.001s

Log in to reply